summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Ball <nullspoon@oper.io>2024-05-04 16:43:31 -0600
committerAaron Ball <nullspoon@oper.io>2024-05-04 16:43:31 -0600
commitd8be16134694b3e0a1459234702ececfb86ebd00 (patch)
treec94a162cbcf8d235a613ce816ad77545d0ae3221
parent395b0e557b28274c0e5480d8f0d190851113e1ea (diff)
downloadports-d8be16134694b3e0a1459234702ececfb86ebd00.tar.gz
ports-d8be16134694b3e0a1459234702ececfb86ebd00.tar.xz
libcap-ng:version from 0.8.3 to 0.8.5
-rw-r--r--libcap-ng/.footprint2
-rw-r--r--libcap-ng/.md5sum2
-rw-r--r--libcap-ng/.signature8
-rw-r--r--libcap-ng/Pkgfile13
4 files changed, 16 insertions, 9 deletions
diff --git a/libcap-ng/.footprint b/libcap-ng/.footprint
index 80e694c..21d131a 100644
--- a/libcap-ng/.footprint
+++ b/libcap-ng/.footprint
@@ -7,12 +7,10 @@ drwxr-xr-x root/root usr/bin/
drwxr-xr-x root/root usr/include/
-rw-r--r-- root/root usr/include/cap-ng.h
drwxr-xr-x root/root usr/lib/
--rw-r--r-- root/root usr/lib/libcap-ng.a
-rwxr-xr-x root/root usr/lib/libcap-ng.la
lrwxrwxrwx root/root usr/lib/libcap-ng.so -> libcap-ng.so.0.0.0
lrwxrwxrwx root/root usr/lib/libcap-ng.so.0 -> libcap-ng.so.0.0.0
-rwxr-xr-x root/root usr/lib/libcap-ng.so.0.0.0
--rw-r--r-- root/root usr/lib/libdrop_ambient.a
-rwxr-xr-x root/root usr/lib/libdrop_ambient.la
lrwxrwxrwx root/root usr/lib/libdrop_ambient.so -> libdrop_ambient.so.0.0.0
lrwxrwxrwx root/root usr/lib/libdrop_ambient.so.0 -> libdrop_ambient.so.0.0.0
diff --git a/libcap-ng/.md5sum b/libcap-ng/.md5sum
index 27fd584..7f708e5 100644
--- a/libcap-ng/.md5sum
+++ b/libcap-ng/.md5sum
@@ -1 +1 @@
-297aacdca53629b26ce37e078f479c78 v0.8.3.tar.gz
+8635fae2b1ead2381a9630d00e8f80b7 v0.8.5.tar.gz
diff --git a/libcap-ng/.signature b/libcap-ng/.signature
index 7972083..eb4fec6 100644
--- a/libcap-ng/.signature
+++ b/libcap-ng/.signature
@@ -1,5 +1,5 @@
untrusted comment: verify with /etc/ports/nullspoon.pub
-RWThnm0RuVZhZk6Fk4FRxW8gd++IATpf0mZ9aoq0yjZG+NKBnjoUKj2fX+WjIez1iZV5Cmc6RC63rnvwIk8dyTpFc1IJxFLVUwE=
-SHA256 (Pkgfile) = ffc64b178e285e1d93a0a8e4524f7e5cf0e0602cc0d3a0f83c37083154606c58
-SHA256 (.footprint) = c33a5b5f1d391fca36e6de037ed0fd6d9f06aabe7364efddd5c010ee96d6e671
-SHA256 (v0.8.3.tar.gz) = e542e9139961f0915ab5878427890cdc7762949fbe216bd0cb4ceedb309bb854
+RWThnm0RuVZhZngif7RueY1TOpfx+qjGRmXc/8VD8T2y/B7fNA+1i7DK8T7NZxAZ2Y8bVUvDtZO37OwiWDsjfUwP+RE2y1RYTAY=
+SHA256 (Pkgfile) = 9e21a77c56f3a82e8a24b90d919e729a152a49b0672f0df2b4d97d79eddf1090
+SHA256 (.footprint) = af883c9985a58bef2d272019a39d8cf86a54b4b0269258a854e3b7fefe040cab
+SHA256 (v0.8.5.tar.gz) = e4be07fdd234f10b866433f224d183626003c65634ed0552b02e654a380244c2
diff --git a/libcap-ng/Pkgfile b/libcap-ng/Pkgfile
index 6db52e3..8c347d2 100644
--- a/libcap-ng/Pkgfile
+++ b/libcap-ng/Pkgfile
@@ -4,14 +4,23 @@
# Depends on:
name=libcap-ng
-version=0.8.3
+version=0.8.5
release=1
source=(https://github.com/stevegrubb/${name}/archive/refs/tags/v${version}.tar.gz)
build() {
cd "${name}-${version}"
+
./autogen.sh
- ./configure --prefix=/usr
+ ./configure \
+ --enable-static=no \
+ --prefix=/usr \
+ --with-python3 \
+ --without-python
+
+ # Fixes https://github.com/stevegrubb/libcap-ng/issues/53
+ sed -i '/PYTHON = $(PYTHON3)/d' bindings/python3/Makefile.am
+
make
make DESTDIR="${PKG}" install
}

Generated by cgit