summaryrefslogtreecommitdiff
path: root/mbsync
diff options
context:
space:
mode:
authorAaron Ball <nullspoon@iohq.net>2016-11-28 23:55:47 -0700
committerAaron Ball <nullspoon@iohq.net>2016-11-28 23:55:47 -0700
commite400c03cf4918625fd7bc8fbe51d860c9351b445 (patch)
treed14221a12e91db63e75e1918d7c1061c9bb23d27 /mbsync
parent944d5ec6d852fc38ab41a67e2417472f59fdbe1b (diff)
downloadports-e400c03cf4918625fd7bc8fbe51d860c9351b445.tar.gz
ports-e400c03cf4918625fd7bc8fbe51d860c9351b445.tar.xz
mbsync:Changed from git to tarball download
With source downloads, we can have md5sum verification as well. This also cleaned up the Pkgfile a bit. The same version (1.2.1) is being downloaded still.
Diffstat (limited to 'mbsync')
-rw-r--r--mbsync/.md5sum1
-rw-r--r--mbsync/Pkgfile39
2 files changed, 14 insertions, 26 deletions
diff --git a/mbsync/.md5sum b/mbsync/.md5sum
new file mode 100644
index 0000000..111c3cb
--- /dev/null
+++ b/mbsync/.md5sum
@@ -0,0 +1 @@
+7ba1a07c7b487a3ab5fef54d0071f1dd isync-1.2.1.tar.gz
diff --git a/mbsync/Pkgfile b/mbsync/Pkgfile
index eb41c0b..d450146 100644
--- a/mbsync/Pkgfile
+++ b/mbsync/Pkgfile
@@ -1,37 +1,24 @@
-# Description: Mailbox synchronizer
-# URL: http://isync.sourceforge.net/
+# Description: Mailbox synchronizer
+# URL: http://isync.sourceforge.net/
# Maintainer: Aaron Ball <nullspoon at oper dot io>
-# Depends on: perl5-timedate cyrus-sasl
+# Depends on: perl5-timedate cyrus-sasl
name=mbsync
-version=isync_1_2_1
+version=1.2.1
release=1
-source=()
-
-gitsource=http://git.code.sf.net/p/isync/isync
+source=(http://downloads.sourceforge.net/project/isync/isync/${version}/isync-${version}.tar.gz)
build() {
- if [[ -d ${name} ]]; then
- cd ${name}
- git reset --hard
- git pull ${gitsource}
- else
- git clone ${gitsource} ${name}
- cd ${name}
- fi
-
- git checkout ${version}
+ cd isync-${version}
- # TODO: Maybe remove this at some point.
- # This is because the git repo doesn't contain the file ChangeLog, which
- # causes autoreconf to fail on Makefile.am.
- touch ChangeLog
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/man \
+ --disable-compat \
+ --with-ssl \
+ --with-sasl \
+ --with-zlib
- autoreconf -fi
- ./configure --prefix=/usr --mandir=/usr/man --disable-compat \
- --with-ssl \
- --with-sasl \
- --with-zlib
make
make DESTDIR=${PKG} install

Generated by cgit